I remember seeing something about this somewhere, but i can't seem to find it now. I have a couple of Online Shell Scripts targeted to Windows computers that, when executed while someone is logged in to the machine, display an empty cmd window while the script is running. I would like the execution to not interrupt/confuse our users.

server: 5.3.47927
client: 5.3.47657

Thanks in advance!
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

1
If you open the xml editor of the script and change the type from job/ policy to something else (e.g. hidden) then it should hide that prompt
Answered 12/15/2011 by: GillySpy
Seventh Degree Black Belt

Please log in to comment
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
We were using an online k-script that was calling "cmd.exe /c" and an uploaded dependency .cmd script. This was also bringing up a blank cmd window, even if we had echo statements in the .cmd script. I tried editing the xml for this and I still get 2 cmd windows popping up, but I think that may be because commands that are running within the .cmd script because I think there were 3 windows before.

However, I tried the online shell script as the original poster was using just to see if it made a difference and I don't see an option to edit the XML when that type of script is selected.
Answered 12/17/2011 by: ncsutmf
Second Degree Green Belt

Please log in to comment
0
One "gotcha" for the offline kscripts. If you edit the xml, it will delete your batch file dependency (ex. kace6565.bat). If you try to re-upload the same batch file (from your kbot-cache) it will not allow you to upload it. To fix it, rename your batch file, and edit the script to use the new name.

Beyond that, it works great.

Casey
Answered 12/19/2011 by: cmccracken
Orange Senior Belt

Please log in to comment
Answer this question or Comment on this question for clarity