Hi,

I'm trying to deliver the Citrix Receiver v3.3 client via Altiris using the command line citrixreceiver3.3.exe /silent command.  When run locally it works a treat.  When I deploy via Altiris it installs silently but produces a config box at the end of the install.  I have even created a wise script to copy the .exe to a local location and run with the switch but I get the same result as soon as Altiris calls the .exe.

I know this is a long shot but I thought I would check to see if anyone else has had a similar problem.  I'm tearing my hair out!

Thanks in advance

Answer Summary:
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

0

Check out this article by Citrix:

How to Suppress the Add Account Window in Citrix Receiver for Windows 3.x

http://support.citrix.com/article/CTX135438

 

Basically, you have multiple chooses in the matter.  If you look at Method 2, it shows that you can use the "/ALLOWADDSTORE=N" to suppress the "Add Account" dialog after the installation.  I tried it out and it worked for me from our Altiris server.  The new Silent Install command would be:

citrixreceiver3.3.exe /silent /ALLOWADDSTORE=N

 

Let me know if it works for you.

Answered 03/18/2013 by: M P
Purple Belt

  • Cannot thank you enough for that. I should have spotted something about that but missed it. I am very grateful for you help. Cheers
  • No problem. It was very strange how that occured only through the remote installation, and when I searched the issue, I saw that this was a complaint from many people. Citrix finally came out with the article after it, but I really think they should link to the article in the Production Documentation with the command-line installation instructions.
  • You're right. It make no sense whatsoever. All switches should be on the list. Thanks again for your help.
  • Seems I celebrated too quickly. Started the deployment today and this screen I was trying to avoid has popped up on users screens. The command line I used was CitrixReceiver3.3.exe /silent /ALLOWADDSTORE=N
    • How about adding a registry value after the installation like the documentation states and see if that works?
      HKLM\Software\Citrix\Dazzle, set AllowAddStore value to N
  • It seems that the AllowAddStore=N simply prevents a user from adding in an account. If I don't configure one then it'll be a mess. I decided to make life harder for myself by embarking on the nightmare of trying this. I have not succeeded as yet.

    In combination with the registry edits we have a silent completely configured deployment.

    Command line used: CitrixReceiver3.3.exe /silent STORE0="mystore;http://myapps.corp.com;On"

    Registry Settings Injected:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\AuthManager]
    "ConnectionSecurityMode"="Any"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Dazzle]
    "AllowSavePwd"="A"
    "AllowAddStore"="A"

    The registry settings work great but an account which is supposed to be http://myapps.corp.com is not working at all. We are running 64 bit as well.

    Any suggestions welcome! Has anyone successfully done this? This is not supposed to be this difficult surely?
Please log in to comment
Answer this question or Comment on this question for clarity
Admin Script Editor
Admin Script Editor is an integrated scripting environment available free here at ITNinja

Share