I've packaged Citrix ICA Client 9.0 for Win32 (after "Client Packaging" with msiexec /a) using an MST comming from Citrix ( http://support.citrix.com/kb/entry!default.jspa?categoryID=149&entryID=3936&fromSearchPage=true), but still have no success.

The important file(s) ssonsrv.exe, ssonstub.dll and ssoncom.exe are n o t installed with Software Distribution via GPO!! Starting installation manually everything works fine.... Installing via GPO with self captured MST files (with Wise Package Studio) the installation doesn't work -> Event ID: 11312 - "A portion of the folder path ' exceeds the length allowed by the system"...

Any idea!?

--------------------------

Michael
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Hi Mikle
I had nearly the same problem in our evironment. We deploy packages by SMS.
I solved it that way.
I downloaded the "Citrix Presentation Server Client Packager" from citrix and created an msi with only the features i wanted (msiexec /a).
When installing that package i did not get "pass-through authenication".
Now i install it with the following command line (we need it quiet):
msiexec /qb- /i <msi-file> ALLUSERS=1 ENABLE_SSON=Yes ALLOW_REBOOT=No
Even in that command line the reboot gets suppressed, after the installation the client has to be rebooted. But it seems like that this property is important. After the restart directly after the installation the citrix client logs in automatically.
I tried to add these Properties directly to the msi file... that didn't work ... don't know why. -
greets wolfgang
Answered 07/07/2005 by: Wolfgang74
Senior Yellow Belt

Please log in to comment
0
Hej,

An administrative install install would solve your problems....

msiexec /a ica32pkg.msi

Packager Setup Menu starts where you can customize your settings and save the .msi file with the features you want to have.
Answered 07/07/2005 by: Priapus
Orange Belt

Please log in to comment
0
@ Wolfgang,

did you ever have success with "msiexec /qb- /i <msi-file> ALLUSERS=1 ENABLE_SSON=Yes ALLOW_REBOOT=No"!?

We are using Webinterface with Authentification-Option "SingleSignOn", aktivate Windows-Authentification (settings in IIS -> Dirctory Security ) to Standardauthentification and integrated Windows Authentification....with no succes [:@]

Only change Webinterface Authentification-Option from "SingleSignOn" to "Anonymous" works.

Any idea!?

@Priapus: Try this one first (i wrote in my post)- with no luck, too.......

greets Michael
Answered 07/14/2005 by: Mikle 01
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity