Hi,

Has anyone packaged this msi?
I can't open it using Wise Package Studio 7. I get an error message saying "Failed to open document". I was hoping to use Wise Install Tailor to create a transform but now i can't. I can open the msi in Orca but was wondering has anyone experienced this before?

Rgds,
Mark
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Hello Mark,

It sounds like you are trying to open the compressed package as supplied by the vendor. I think you need to use msiexec /a to uncompress the MSI in order to customise it.

Have a look at this link which covers the basic procedure.

Regards,

Spartacus
Answered 05/25/2007 by: spartacus
Black Belt

Please log in to comment
0
Hi Spartacus,

Yes, I've extracted that msi out of the compressed msi but the extracted msi gives the exact same error message!

any other suggestions?
Answered 05/25/2007 by: mark_holland21
Fourth Degree Green Belt

Please log in to comment
0
Just stumbled across this article after you said it still wouldn't open and it seems this is a problem with Wise Package Studio being unable to handle some of the tables in the Citrix MSI.

The conclusion seems to be that you will need to use ORCA (or InstallShield if you have that available to you) to create your transform.

Regards,

Spartacus
Answered 05/25/2007 by: spartacus
Black Belt

Please log in to comment
0
Thanks Spartacus,
I was afriad that would happen!
Answered 05/25/2007 by: mark_holland21
Fourth Degree Green Belt

Please log in to comment
0
Another link that may be of help of creating your transform using ORCA and DebugView.
http://forums.altiris.com/messageview.aspx?catid=19&threadid=42299
Answered 05/25/2007 by: AngelD
Red Belt

Please log in to comment
0
You have to create an adminstrative install point with the msiexec /a command. Their MSI not only supports it but provides a slick interfaces that lets you fully customize the install.
Answered 05/30/2007 by: Bladerun
Green Belt

Please log in to comment
0
If you have done the admin point and want to use "Program Neightborhood" you can also make changes to the pn.ini.

First install the application and start it and configure the connection, then open the pn.ini on the local machine. Copy / paste the information into your admin point \Progam files\Citrix\Ica Classic\pn.ini I also pasted the info into pn.scr, dont know if you have to write the information in both places, but I did it to be on the safe side.

/M.N
Answered 05/30/2007 by: Mackan75
Orange Belt

Please log in to comment
0
I'm having the same issue. We use WPS 7.0 here for every automation and can't get it open with WPS. I am going to try calling Symantec (Wise) support and see if they have a fix for this. I'll keep you posted! Thanks -

Richard Fleites
Answered 03/21/2008 by: rfleites
Yellow Belt

Please log in to comment
0
Had the same problem - sounds like you need a hot fix to open this up in WPS - KB_33095_Hotfix.EXE

See Altiris KB Article 33095 for more info.

Regards,
Rob.
Answered 03/25/2008 by: MSIPackager
Third Degree Black Belt

Please log in to comment
0
I did this package and it is not supported by wise as it has tables for each language.so you have to reapckge this msi using orca.
Answered 03/31/2008 by: packengg
Orange Belt

Please log in to comment
0
I found a link on Citrix's site that helped me get the first part of the package built. I am still trying to find where it stores the Pass-through authentication.

msiexec /a c:\ica32pkg.msi
http://support.citrix.com/article/CTX112961&searchID=43816528
Answered 04/27/2009 by: WCHILCOTE
Yellow Belt

Please log in to comment
0
Is the same problem occuring for Citrix ICA Client 9.x ?
Is the fix included in WPS - 7.0 SP3 ?
Answered 03/10/2010 by: Rakesh_Mali
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity