Ive created a package for Paint Shop Pro 8 using wise, ive tired to change the directory its installed to by changing the script after costfinalize like it said on the website. Im trying to get it to point to the D drive. but it still defaults back to the C: anyone know how to change this?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Did you see this FAQ?

How do I control the destination drive of my package?
http://itninja.com/question/do-you-have-a-sample-protocol.ini?5

Hope this helps,
Bob
Answered 03/08/2004 by: bkelly
Red Belt

Please log in to comment
0
yes ive tried that, but it says that that rootdrive will not work BC it points to the windows "program files" folder, it said to use this instead, but it is not working either
Answered 03/08/2004 by: nevik
Yellow Belt

Please log in to comment
0
Make sure that you add the ROOTDRIVE property in caps. and set it to D:\

It should then install your app to D:\Program Files\[Installdir]

If it isnt then make sure the drive is available during the install.

You could also go to the Property Table and change all of the paths to point to D drive.
Answered 03/08/2004 by: MSIMaker
Second Degree Black Belt

Please log in to comment
0
rootdrive is in all caps
Answered 03/09/2004 by: nevik
Yellow Belt

Please log in to comment
0
Hi Nevik - not sure if you still need a solution for this. A few months ago, I was having a hard time getting the Install Directory changed to D:\ (using Wise). I tried RootDrive with no luck. I finally added a custom action to my script:

Created a new property called MYDIR (or something unique) and entered desired drive letter for the value (i.e. D:\)

After the Cost Finalize entry in the User Interface sequence, insert a Set Directory custom action

Enter a unique Custom Action Name - doesn't matter what it is as long as it's unique

For the Directory field, clicked on the Browse button, and chose the folder you want the app to install to, and click OK. The Directory field will be populated with the property name of the folder (i.e.INSTALLDIR)

In the Directory Value field, entered the custom property you created in all caps/square brackets, followed by the folder path you want the application to install to: i.e. [MYDIR]Program Files\Windows Resource Kits\Tools. Click OK

It worked like a charm.
Hope this helps.
Answered 03/19/2004 by: Rhonamac
Yellow Belt

Please log in to comment
0
Does any1 have an idea why this command isnt working:

MSIEXEC /i "Path to MSI" ROOTDRIVE=D:\
Answered 11/11/2004 by: oofemioo
Blue Belt

Please log in to comment
0
I've found the rootdrive command option to be problematic - its works on most occasions, but some vendor supplied MSI's have some weird properties - one I had had DIRPROPERTY1, DIRPROPERTY2 etc that all had to be set to D: as WELL as rootdrive ... I found all this by extensive logging of the installation and also looking at the file table and tracing the directory structure there.

Hope that helps.

Paul
Answered 11/12/2004 by: plangton
Second Degree Blue Belt

Please log in to comment
0
Using the SetDirectory Custom Action in WISE works fine.

But is there any reason why ROOTDRIVE won't work.


We should all be concerned if TRANSFORMS as a property stops working!!
Answered 11/12/2004 by: oofemioo
Blue Belt

Please log in to comment
0
If you write the custom action, it works. But if you install the msi in silent mode, it again takes the C:\Program Files as install directory.
Answered 06/11/2005 by: murali_kbhat
Yellow Belt

Please log in to comment
0
For the change directory to work in silent mode, use the custom action under the "Normal Execute Immediate/Deferred" sequence.
Answered 05/19/2006 by: s.diwakar
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity