Hi all...

So I've got a bit of a weird question/problem.

Basically, I have a client that has Excel 2003 and 2007 installed.  Excel 2007 is installed natively, and Excel 2003 is thinapp'd.

The problem they have, is that when they have a document open in Excel 2003, and they click a hyperlink, it opens in excel 2007. This makes sense because Excel 2007 was installed more recently.

What the client *wants* to happen is, when they click on a hyperlink in excel 2003, it opens in excel 2003. This isn't as easy as changing a file association, because thats not what handles this particular area.  I think it has something to do with excel knowing that its attempting to open a spreadsheet "object", and just passes it to the object handler (which is the more recently installed 2007 version).

Any idea how I could fix that? Or make .xls open with Excel 2003 and .xlsx with 2007?

Sorry if my post makes no sense, I'm just getting over a cold and my mind is stuffed D:

2 Comments   [ - ] Hide Comments


  • Just..... out of shear curiosity I'll ask: Why not remove 2003? Seems kind of unnecessary?? or am I missing something?
  • The area thats using it claims compatibility issues with some of their older spreadsheets... so they've asked for both versions
Please log in to comment

Answer this question or Comment on this question for clarity




This is very intersting scenario. I will trying this scenrio by having Exceel 2003 Thinapp'd with local Excel 2007 this weekend.

I assume that the target of the hyperlink is an another Excel file.

As of now the only simple workaround would be:

1.Right click on .xls -> Open with Excel 2003 by default. (I am aware that it is thinapp, but I think there will be an option to this)

2.Right click on .xlsx -> Open with Excel 2007 by default. 

 I am not sure if this works as I dont have the machine and the thinApp ready. May be you can give this a try and let us know.


Answered 01/02/2014 by: rushi.ware
Senior White Belt

  • Nah doesnt work... not when one of the versions is thinapp'd
Please log in to comment