I have made a multi language installation for office 2010 with the following config.xml

And of-course copied the extra language files 

<AddLanguage Id="match" ShellTransform="yes"/>
<AddLanguage Id="en-us" />
<AddLanguage Id="nl-nl" /> 
<OptionState Id="OfficeMUI" State="local" Children="force" /> 


This works and on a dutch OS office is Dutch, on a English OS it is English.

However the setup matches for some reason the regional format (date time decimal etc etc) this setting needs to be on Dutch even in the English OS.

But then the setup mui is in Dutch the shortcuts in the start menu are in Dutch.

Why is this a problem? underwater everything is dutch so there is no link to signature but to handtekening which gives problems to a script for creating automatic signatures.


Question, how can i override the [Setup user interface (UI): the language of the installation.]

0 Comments   [ + ] Show Comments


Please log in to comment




I found out that the problem is in the following registry key.

[for windows 7]: reg add "HKEY_CURRENT_USER\Control Panel\International" /v LocaleName /t REG_SZ /d en-us /f

[For Windows XP]: reg add "HKEY_CURRENT_USER\Control Panel\International" /v Locale /t REG_SZ /d 00000409 /f

This one is set to nl-nl and when i change it to en-us the setup, etc etc is in English.

This way the format (within regional settings) is set to English but all the time, date, number, currency etc etc are still in Dutch.

And after the install i return it back to what it was.


This is not the most pretty way but it works.

Still i don't understand why the setup looks at this attribute instead of the windows language.


Best regards,



Answered 08/12/2013 by: Jasper@nki
Senior White Belt

Please log in to comment
Answer this question or Comment on this question for clarity