Hi,

I have a problem on my newly created MSI, I've created this MSI through setup capture, though all the processes seemed to install fine, at the end, when I try to create a MST file for the said MSI, the installation cannot seem to simulate / proceed. It pops up a dialog box saying that "Setup requires Internet explorer version 5.0.2314.0 or above" and it won't let the installation continue. My current version of Internet Explorer is 6. I don't know what seems to be the problem, I've also checked on the MSI system requirements through installer editor in Wise Package 7.0. It says that any version of IE will do.

Here is my current setup:

Running Wise Package 7.0 SP3 on VMWare Workstation 6, using Windows XP Professional SP2 as OS in simulating the install

Hope anyone can give help / feedbacks, thanks! :)

To admin: I'm sorry for the double post, I'm not sure under what thread topic exactly to post this
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
I'm not sure why you need to create an MST if you've captured the MSI in the first place, but anyway - does the MSI install OK on it's own?

If so what have you done in your MST and how did you create it?

Cheers,
Rob.
Answered 01/18/2010 by: MSIPackager
Third Degree Black Belt

Please log in to comment
0
If IE is part of your build (and it's hard to imagine how it wouldn't be...), remove the 'System Requirement' option.
Answered 01/18/2010 by: VBScab
Red Belt

Please log in to comment
0
Running Wise Package 7.0 SP3 on VMWare Workstation 6, using Windows XP Professional SP2 as OS in simulating the install


go to altiris

and type in 1540 read this
and also type in 2948 and read this as well

in wise open your msi ( windows installer editor)
go to tools > options > click on the general tab look at the compiler options

what you want is " add custom actions for predefined folders in merge modules" tick this option

and then there is no more need to pull your hair out [:D]
Answered 01/18/2010 by: cygan
Fifth Degree Brown Belt

Please log in to comment
0
thanks for the solution, I've already solved that issue on the internet explorer version, but I have another issue that popped up, which is regarding the SA password

I've used this article so solve that SA password issue, but i can't seem to create the final installer, I have problems in creating the single.exe file in the end, the error says: "the runtime C:\Program Files\Altiris\....\runtime\restart.exe does not exist" , when I selected the option to download runtimes, I just cant seem to find restart.exe from the list of available runtimes.

Here is the article that I've used in solving the SA password issue.

Problem/Symptoms

During runtime the following error is received: "A strong SA password is required for security reasons. Please use the SAPWD switch to supply the same. Refer to readme for setup details."
Environment

MSDE merge modules
SQL Server merge modules
Cause

MSDE merge module doesn't allow blank SA passwords by default.
Resolution

Microsoft is recommending bootstrapping the MSDE .EXE to an installation rather than using the merge modules to install MSDE with an installation.

Wise makes this easy for you by adding the MSDE to the prerequisites page in Installation expert. Follow the steps below to add MSDE runtime to an .EXE wrapper:
In Installation Expert, select Build Options page and select Single File .EXE from the .EXE options drop down list. You may receive an error message indicating to change the Media type if you have external uncompressed files or external cabs set in the media options. A Single file .EXE (only valid for files inside .MSI) can only be used when the Media type of internal compressed files. If you have the Media page set to external uncompressed or external cabs, you need to use the .EXE that launches external .MSI option.
Select Prerequisites page from Installation Expert.
Click Add then select Runtimes.
If the MSDE 2000 Release A runtimes is not on your computer:

1. Select Help > Download Redistributables. Mark the Other Vendors' Web Site option and download the MSDE 2000 runtime.
2. Double-click the downloaded MSDE2000A.EXE to extract the MSDE installation files to your computer.
3. Specify the path to the MSDE files when prompted when incluyding the runtime

The MSDE runtime will appear in the list. Selecting this will include the runtime in an .EXE wrapper that is placed on the computer prior to executing the .MSI. The MSDE runtime should be on the computer to add it here, but can be downloaded by following the instructions on the MSDE Release A Runtime dialog during the process of including the runtime.

If you have a blank password, this will cause this error to appear:

If you would like to use a blank SA password, you can set BLANKSAPWD=1 in the property table of the merge module. Included with this article is a link to Microsoft's article on the switches that can be used for the MSDE setup.

This issue is also applicable to SQL Server merge modules.
Answered 01/19/2010 by: pagsi23
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity