If I run amptools get

I get....

[2017-03-20.16:03:34][AMPTools:AgentConfig::LogAll    ] Agent Configuration Values
[2017-03-20.16:03:34][AMPTools:AgentConfig::LogAll    ] KACE Agent version 7.0.763 Oct 21
[2017-03-20.16:03:34][AMPTools:AgentConfig::LogAll    ] ---------------------------------
[2017-03-20.16:03:34][AMPTools:AgentConfig::LogAll    ] debug:                     true

Why?

I've tried running the script to disable debug, I've even stopped all running Kace services and processes, manually changed amp.conf 

Running c:\>amptools debug=false

Results in errors saying that only "host" is configurable; 

"the key 'debug' is not host, and host is the only key modifiable"

On starting the services amp.conf get re-written with debug=all!!!    Grrrr!

Nothing works.

Help?!
2 Comments   [ + ] Show Comments

Comments

  • This seems to be a bug. However, the logs are now less chatty with debug=false
  • Yes that is what I am thinking.

    In general I like v7 however I'm finding that patches detection is taking 5+hours and whilst this is happening I cannot get the agent to update the inventory. I'm strongly thinking of going back to version 6...
Please log in to comment

Answers

1
AMPTools will not be able to change debug flag from 7.0 release

With 7.0 release, agent debug flag can only be controlled from System console from under the Organization detail view page under the Communication Settings section.


Answered 03/20/2017 by: AbhayR
Sixth Degree Black Belt

  • Thanks.

    Ok so I think I've turned off debug from the KACE console...agents are still showing debug=all though...

    I disabled (unticked) Enable Server Debug in Agent Settings

    Is this configured anywhere else?

    I have left this for 24hours so if an inventory is required this should have occured by now ;)
    • You might have to restart the Agent or the machine so that when the Agent reconnects, it will pickup the new settings
      • ok rebooted a test subject ;) No joy. Still in debug mode...I must have missed something somewhere.

        Interestingly....the amp.conf now says debug=false however a amptools get says debug true!

        Odd?!
Please log in to comment
Answer this question or Comment on this question for clarity

Share