We are preparing to move from Office/Project 2010 to 2013. So far the config for Office has gone well but I am currently stuck with trying to hide the Planning Wizard prompt when Project 2013 is opened for the first time. I have tried the solutions given in this post (http://www.itninja.com/question/planning-wizard-microsoft-project-2010) however, it doesn't appear to be working for me in this instance.

I first tried installing Project 2013, which is configured to unisntall 2010 if it exists, and then added the registry keys manually afterwards before opening Project. No luck. then I tried importing the keys into the MSP file for Project 2013 so they would be applied during the installtion. Still no luck. The keys appear in the registry but do not seem to have any affect when I launch the application.

Any ideas?

-Adam

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

1
I had the same issue providing MS Project 2010 over our Citrix servers.
It is suggested to enable the option "Disable Opt-in Wizard on first run" in the Microsoft OCT when creating your MSP file.
It is located under the following: Setup \ Features \ Modify user settings
By enabling this setting, the wizard will not display the 1st time users run an Office 2010 application.

But users who have previously accessed Project 2007 have a Global.MPT file in their profile (username\AppData\Roaming\Microsoft\MS Project\12\1033\Global.MPT)
So the MS Project Planning Wizard will show up even if the installation of Project 2010 was set not to show the wizard.

You could of course delete the "username\AppData\Roaming\Microsoft\MS Project\12\1033\Global.MPT" of your users. But how to find out who of your hundreds or thousands of users have that file stuck in their profile could be a pain.
Set the following key in the login scripts of your servers so the Planning Wizard does not display:
powershell script:
_writeValue "HKCU:\Software\Microsoft\Office\14.0\MS Project\Previous Global" "No Alert" "1" "Dword"
Answered 03/31/2015 by: jaywy1
White Belt

Please log in to comment

Answers

0
My guess is that there are other registry keys involved in a "first run" scenario. You will need to run a capture tool during the first run operation and see what other keys you need to add, so that the first run does not happen.
Answered 08/04/2014 by: EdT
Red Belt

  • You are probably right. We have decided that we will let the prompt show for users and let them decide on whether or not they want to carry over previous settings or start fresh. We debated it and are of the opinion that, at least in our situation, it's not a big issue.

    Thank you all for the help and replies. Much appreciated.
Please log in to comment
0
As you don't provide specifics of what you have done, it is difficult to spot potential errors, so first of all, have you changed the following registry key to the correct office version for 2013?

HKCU\Software\Microsoft\Office\14.0\MS Project\Options\PlanningWizard

I believe Office 2013 is Office 15.0.  Install Project, run the planning wizard the first time, then go to HKCU and track down the appropriate entry and check it against yours.  The problem you face is that if you deploy with a service account, it will not be able to update the HKCU keys until Project runs for the first time. In theory it should repair the keys before project is launched but it depends on how the keys are added.
Answered 08/01/2014 by: EdT
Red Belt

Please log in to comment
0

Here is the exact text from the registry file I have tried to add manually after the install and import into the MSP.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\MS Project\Options\PlanningWizard]
"PlanningWizard Cases"="11111111111111111111111111111111111111111111111111111"
"Display PlanningWizard"=dword:00000000

I should have mentioned I had changed the path to account for 2013. Right now I am installing as the user so there is not service account in the way at this point. We use SCCM 2012 to deploy and thus far, I haven't had issues adding CU registry keys to Office 2013 and deploying via SCCM which uses its own account to run the install.

Answered 08/01/2014 by: quattro004
Orange Belt

Please log in to comment
Answer this question or Comment on this question for clarity