Install of KBOXagent fails on sanity check because of missing com.apple.loginwindow -- however there is a com.apple.loginwindow.plist. This is on a system running MacOSX 10.6.3. Also happened on 10.6.5 too.

Dec 6 09:11:50 dhip-055 sudo[371]: support : TTY=unknown ;
PWD=/Users/support ; USER=root ; COMMAND=/bin/bash -c ls
/Library/KBOXAgent/Home/bin/setkbox 2>/dev/null
Dec 6 09:11:50 dhip-055 sudo[389]: support : TTY=unknown ;
PWD=/Users/support ; USER=root ; COMMAND=/bin/bash -c line=`hdiutil
attach "/tmp/kaceagent.dmg" | tail -1` && dev=`echo \$line | cut -f 1
-d \ ` && mountpoint=`echo $line | cut -f 3- -d \ ` && echo mp
$mountpount dev $dev && installer -pkg "$mountpoint/KBOX Agent.pkg"
-target / && hdiutil detach "$dev" &&
/Library/KBOXAgent/Home/bin/kagentctl stop &&
/Library/KBOXAgent/Home/bin/SMMPctl stop && rm -rf /tmp/kaceagent.dmg
Dec 6 09:11:51 dhip-055 hdiejectd[401]: running
Dec 6 09:11:58 dhip-055 SystemStarter[428]: "/Library/StartupItems"
failed sanity check: path was created after boot up
Dec 6 09:11:58 dhip-055 defaults[436]: \nDomain com.apple.loginwindow
does not exist
Dec 6 09:12:00 dhip-055 SystemStarter[440]: KBOXAgent (441) did not
complete successfully
Dec 6 09:12:00 dhip-055 SystemStarter[440]: The following
StartupItems failed to start properly:
Dec 6 09:12:00 dhip-055 SystemStarter[440]: /Library/StartupItems/KBOXAgent
Dec 6 09:12:00 dhip-055 SystemStarter[440]: - execution of Startup
script failed
Dec 6 09:12:07 dhip-055 sudo[459]: support : TTY=unknown ;
PWD=/Users/support ; USER=root ; COMMAND=/bin/bash -c
/Library/KBOXAgent/Home/bin/setkbox kbox1000 < /dev/null 1>/dev/null
2>/dev/null
Dec 6 09:12:08 dhip-055 sudo[480]: support : TTY=unknown ;
PWD=/Users/support ; USER=root ; COMMAND=/bin/bash -c ls
/Library/KBOXAgent/Home/bin/setkbox 2>/dev/null
Dec 6 09:12:08 dhip-055 sudo[488]: support : TTY=unknown ;
PWD=/Users/support ; USER=root ; COMMAND=/bin/bash -c cat
/Library/KBOXAgent/Home/data/version 2>/dev/null
Dec 6 09:12:12 dhip-055 hdiejectd[401]: quitCheck: calling exit(0)
Dec 6 09:14:13 dhip-055
/System/Library/CoreServices/CCacheServer.app/Contents/MacOS/CCacheServer[218]:
No valid tickets, timing out
Dec 6 09:25:04 dhip-055 login[534]: USER_PROCESS: 534 ttys001
Dec 6 09:25:31 dhip-055 sudo[538]: support : TTY=ttys001 ;
PWD=/Users/support ; USER=root ; COMMAND=/sbin/SystemStarter stop
KBOXAgent[/align]
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
So phase 2, uninstall works fine:


Provisioning Log
[hr]
[hr] [12/06/10 11:13:53 AM] Begin provisioning...
[12/06/10 11:13:53 AM] Executing Unix platform provisioning.
[12/06/10 11:13:53 AM] Probing tcp ports for accessibility.
[12/06/10 11:13:53 AM] Port 22 [ssh] open.

STEP 1: CONNECT TCP/SSH - SUCCESSFUL


STEP 2: AUTHENTICATION - SUCCESSFUL

[12/06/10 11:13:53 AM] Target is Darwin.
[12/06/10 11:13:53 AM] KBOX Agent detected via ssh query.
[12/06/10 11:13:54 AM] Version is 5.1.31311.
[12/06/10 11:14:00 AM] Removing KBOX Agent.

[12/06/10 11:14:00 AM] waiting for 84...... done.

STEP 3: PUSH SCRIPT\PROVISIONING - SUCCESSFUL

[12/06/10 11:14:00 AM] KBOX Agent NOT detected via ssh query.
[12/06/10 11:14:01 AM] End provisioning run.
Reinstall still generates the errors above. Tried copying com.apple.loginwindow.plist to com.apple.loginwindow (ie. addl. file) but no change. Looking at the log at startup shows:

Dec 6 11:11:05 dhip-055 com.apple.launchd.peruser.501[106]
(com.apple.Kerberos.renew.plist[128]): Exited with exit code: 1
Dec 6 11:11:07 dhip-055 kace.smmpagent.bootup[50]: No status fifo ...
waiting ...
Dec 6 11:11:37: --- last message repeated 14 times ---
Dec 6 11:11:37 dhip-055 kace.smmpagent.bootup[50]: No status fifo ...
waiting ...
Dec 6 11:12:07: --- last message repeated 14 times ---
Dec 6 11:12:07 dhip-055 kace.smmpagent.bootup[50]: No status fifo ...
waiting ...
Dec 6 11:12:18: --- last message repeated 5 times ---
Dec 6 11:12:18 dhip-055 login[153]: USER_PROCESS: 153 ttys000
Dec 6 11:12:19 dhip-055 kace.smmpagent.bootup[50]: No status fifo ...
waiting ...
Dec 6 11:12:41: --- last message repeated 10 times ---
Dec 6 11:12:41 dhip-055 kace.smmpagent.bootup[50]: Timed out! No
agent running, kill the child process and exit

Dec 6 11:13:46 dhip-055 kace.smmpagent.bootup[50]: FINISH: 52


[/align]
Answered 12/06/2010 by: Rurik13
Senior Yellow Belt

Please log in to comment
0
Have you tried logging in with the same credentials locally (not via Provisioning) and manually running the KBOX Agent.pkg installation? Do you get the same results, and if so do you see more verbosity in the console/install log? SystemStarter generates these kinds of errors when unable to write to /Library/Preferences/loginwindow.plist and /Library/StartupItems/ -- both of these should be set to system owner r/w and admin/wheel groups, respectively, read-only. You're using Kerberos authentication so that might be a possible factor in passing through the install commands via sudo/root?
Answered 12/07/2010 by: 1erik
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity

Share