hi guys,

i have 2 packages, created with WFWI, that are supposed to create files under the user profile, in application data.

instead, the files are created under C:\WINDOWS\system32\config\systemprofile\Local Settings\Application Data

how can i fix this?

thanks!
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
C:\WINDOWS\system32\config\systemprofile\Local Settings

This folder contains the profile of the Local System account. Could it be you're installing your MSI using some sort of distribution system? Cause these tend to do installs with these credentials. Still, the MSI's autorepair functionality should put the files in place for each user if setup correctly.

Some things that come to mind:

Have a look at the ALLUSERS property in your MSI, make sure it's set to 1 (in this case). Also check the components that contain the files, make sure they have the correct component path ([AppDataFolder]) and a good keypath. Then finally check that you have correctly setup a trigger for self-heal (I'd guess an advertised shortcut).

Hope this helps

PJ
Answered 10/02/2009 by: pjgeutjens
Red Belt

Please log in to comment
0
ok i will try your suggestions. and yes, i'm distributing with bmc.

thanks!
Answered 10/02/2009 by: kardock
Second Degree Green Belt

Please log in to comment
0
The reason you're getting this behaviour is due to BMC. Go and have a look in your publish folder for the application, for a file called 'parameters.txt'. In there, there should be a parameter called 'userobjs'. Make sure this is set to true.
userobjs=true

Do not make the change directly in the .txt file, because it will get overwritten next time you 'repackage'. Instead you should make this change by clicking on the small 'Channel Property' button near the top of your BMC package, and looking under the Parameters tab. Let me know how you get on.
Answered 10/07/2009 by: captain_planet
Second Degree Brown Belt

Please log in to comment
0
thanks for this information.

but i can see this in the doc;
[font=minion-semibold][font=minion-semibold][left]The channel parameter [font=lettergothic-bold][font=lettergothic-bold]userobjs [font=minion-semibold][font=minion-semibold]is set to true, and the user is not logged[/left][left]on to the machine[font=minion-regular][font=minion-regular]—If the userobjs [font=minion-regular][font=minion-regular]parameter is set in the package[/left][left]directory or in the channel.txt [font=minion-regular][font=minion-regular]file of the package in the tuner’s[/left][left]workspace, verify that a user is logged on to the machine to install the[/left]package.

does it mean that it won't install if no one is logged?

thanks!
Answered 10/08/2009 by: kardock
Second Degree Green Belt

Please log in to comment
0
Hmmm. I guess if you're using Policy Management, you may want to look at these values:

logon.notify=true
logon.action=updatestart

But if you're installing them as advertised applications then you should be ok.

For more detailled info, you're best consulting page 154 of the BMC Application Packager's Administrators Guide. [;)]
Answered 10/08/2009 by: captain_planet
Second Degree Brown Belt

Please log in to comment
Answer this question or Comment on this question for clarity