Hi all,

I need to customize the file locations in Business Objects for 'all users'.
It writes its values to

HKCU\Software\Business Objects\Suite 11.5\default\BusinesObjects\"MY LOG ON ID" User Prefs

let's say my log on to Bus. Obj. ID is Gizsha

HKCU\Software\Business Objects\Suite 11.5\default\BusinesObjects\Gizsha User Prefs

Now when I log on with a different ID, I have to set the file locations again.

Does anyone know the variable for this?

Thanks so much.

Gizsha
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Assuming that your username you login into Business objects os the same as you logon name, you'll need to create a custom action to set the username as a property.

You need to create a 'Set Property' custom action.
Under the Property name setting enter "USERNAME" (without the quotes, or you can call this whatever you'd like)
Under the Property Value enter "[%USERNAME]" (without the quotes, this pull the current USERNAME from the environment variables.

So your registry key will look like this

HKCU\Software\Business Objects\Suite 11.5\default\BusinesObjects\[USERNAME] User Prefs

Hope that makes sense.
Answered 08/27/2007 by: michaelnowell
Second Degree Blue Belt

Please log in to comment
0
Hi,

Thanks for your reply.

This is what I did.
Created a property USERNAME, Value USERNAME

Custom Actions, opened Set Property.
Name: Set Property
Property: from the drop down list i selected USERNAME
Value: %USERNAME%

Was this correct? Probably not.

It didn't fix the problem.

Please let me know what I did incorrect.

Thanks.
Answered 08/28/2007 by: gizsha
Purple Belt

Please log in to comment
0
the value is not %username% it is

[%Username]

lookup the word "formatted" in the SDK for more detail on how this works.
Answered 08/28/2007 by: jmcfadyen
Fifth Degree Black Belt

Please log in to comment
0
Either use the %USERNAME% environment variable as John suggested ([%USERNAME]) or if you're gonna use the USERNAME property ([USERNAME]) then make sure it's not predefined in the Property table and the NOUSERNAME property is to 1 as this would prevent the USERNAME property from being set to the value from the registry.
Answered 08/28/2007 by: AngelD
Red Belt

Please log in to comment
0
Hi guys,

Sorry for the late reply. Changed jobs in the meantime.

Anyway, the solution turned out to be [LogonUser]
HKCU\Software\Business Objects\Suite 11.5\default\BusinesObjects\[LogonUser] User Pref

Thanks for your help.

Gizsha
Answered 09/27/2007 by: gizsha
Purple Belt

Please log in to comment
Answer this question or Comment on this question for clarity