I application "Boland CaliberRM" version 9.0.847.

In User interface mode Shortcuts are installed in ALLUSERS , but in Silent (/qb) i am getting the shortcuts only in one user (application are installed in that user)
Solution tried :
1. Propery ALLUSERS=1 added
2. Propery Applicationuser = Allusers given,
3. Custom action which are in UI Sequience is calling "Display dialgog", if i comment these Custom actions , then it is behaving as the same issues (i.e., shortcuts not getting Installed in ALLUSERS)

Can any one know wat will be the problem.

0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


Hey mekaywe...

How are you installing the package, per-user or per-machine?

There are different behaviors when you use one and when you use other ...

If you try to install with a local admin account and ALLUSERS=1 the shortcuts may be appears in the allusers "profile" ...


ALLUSERS=NULL: This installs the package for the current user.

ALLUSERS=1: This installs the package for all the users on the machine provided the user has administrative privileges. If the current user running the setup on Windows NT or 2000 does not have administrative privileges, then the setup errors out and aborts.

ALLUSERS=2: This checks the user’s privileges for administrative rights. Pending the outcome of this check, it installs for all users if the user has enough administrative privileges; otherwise, it installs for the current user.

link: http://community.installshield.com/printthread.php?t=141310
Answered 04/15/2009 by: clyrigham
Orange Belt

Please log in to comment
There are different behaviors when you use one and when you use other ...That doesn't account for the difference between silent and non-silent, though.

In all probability, the package author omitted to set the Custom Actions which set the properties which contain the profile folder's names (single user and all users) so that they execute at least once. They probably exist only in the User Interface sequence and thus don't get executed in silent installs. You can either copy them into the Execute Immediate sequence or set to execute at least once. It really doesn't matter which way you do it. The quickest way to do that is find an InstallShield-authored MSI and copy the CAs from there (e.g. SetAllUserProfileNT, it's something like that).
Answered 04/15/2009 by: VBScab
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity