Hi,

My company is about to introduce Power User rights on our network and I am having problems deploying Autocad products to Aa power user. Basically unless you install the app as a local user who has admin rights it does not install the licensing service. We use Zenworks to deploy our apps and usually apps will deploy that need admin rights as zenworks should elevate the rights. I have tried many different things to fix this problem i.e. give full controll rights to Autodesk entry in registry, give full controll rights to program files folder. I have tried different tools on the web to run the install as admin but these tools I use dont support unc paths and that is how we deploy our apps.

Someone must have depployed these products to users with power user rights. I have tried Autodeesk support and they are useless!

Hope someone can help.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
In my experience with Autodesk products the vendor MSIs have a builtin LaunchCondition of AdminUser = True. I just killed this condition in my transform and ensured my transform also doled out enough rights in the registry and filesystem and it worked.
Answered 12/12/2006 by: fosteky
Purple Belt

Please log in to comment
0
You didn't specify which version so I'm going to guess it's one of the latest ones. This package has a special setup available on the CD provided by the vendor that creates a custom network installation. There didn't seem to be very much documentation on this that I remember. During this custom installation it will ask you things such as your serial number, install log location, etc. After it is completed you will have a deploy.exe along with a distribution folder that contains an msi and distribution files. In zenworks we used a simple AO with the following parameters:

Path to file:

\\server\share\adminimage\deploy.exe

Parameters:

"aclt"

Working Directory:

\\server\share\adminimage\


Forgot to add that you need to set the environment in the AO to Run as Unsecure System user.
Answered 12/12/2006 by: joedown
Second Degree Brown Belt

Please log in to comment
Answer this question or Comment on this question for clarity