Hello,
I created an Asset Type called "User" and imported my list of users (just the names) via a CSV file. I then added fields "Location" and "Device" (using the asset information for Location and Device) so I could map users to Devices and their physical location. I started adding data directly through the Assets list. Part way through, I decided I needed a "Department" field as well. I added that field in Asset Types to the User Asset Type. When I went back to Assets and filtered by the User type, I had Name, Location, and Device columns, but no Department column. I looked at the Column Visibility selector and saw that it lists the columns available as Name, Asset Unique ID, Location, Device, Device. Selecting the 2nd Device screws up the table and changes the location of the Device data that I added. There is no option to add the Department column, yet the Department field shows up in the Asset Type configuration for the User type. I can also add Department data when editing a User. It just will not show up on the list screen.

Is this a bug, or is there something I can do to fix this and show all the proper Asset Fields on the List Screen for User assets?

1 Comment   [ + ] Show Comment

Comments

  • There is no default Asset Type for "User", at least not in my KACE box. It may have been deleted for some reason, but it was not there when I came on in this position.
Please log in to comment

Answers

0
you are correct, there is no Asset type of User, however when you create a field in any Asset Type, when you scroll down the available options you will see a User option. If this field is added to your Asset Type, when you add an Asset of that type you will see the User field dropdown. Associating the Asset with the User will mean if you look up a user record in Settings>User you will see the User "owns" that Asset

Answered 12/11/2015 by: Hobbsy
Red Belt

Please log in to comment
0
You may be going about this back to front, as there is already a User field that you can add to any asset type, which is a preformed field. Within the user record in KACE you are also able to store information such as location. The issue may be that KACE is getting confused between your User field and the actual user field that can be added in. 
Answered 11/24/2015 by: Hobbsy
Red Belt

  • There is no Asset Type for "User". At least not in my implementation. It may have been deleted before I joined this team, but it was not there when I started. There were default "Location" and "Device" Asset Types, however. And the two fields that are getting confused are Department and Device.
Please log in to comment
Answer this question or Comment on this question for clarity