I have an application that I deploy (miktex). Now I have a need to deploy a folder to All Users\application data. Any package that I make will not create directories into all users\application data. Can someone fill me in as to why?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
1./ What are you using to make your package?

2./ What are yout trying to accomplish exactly by creating a folder there?

Feed me details pls so I can help..
Answered 12/03/2007 by: Coriolus
Orange Belt

Please log in to comment
0
Using wise package studio.

Need to place a folder with everyone having modified access. We have an application that is looking there for files. The app is already deployed.
Answered 12/03/2007 by: pisanom
Senior Yellow Belt

Please log in to comment
0
Do you test your packages prior to deployment? If not, do so from this day forward.

When you send your package do you specify ALLUSERS=1? That could solve your problem.

Test the 'ALLUSERS=1' option on a test machine and see if that solves it, if it does, remotely uninstall the application from the machines and then reinstall it. If it doesn't maybe a registry hack or something may be what you need.

TEST! TEST! TEST! :)
Answered 12/03/2007 by: Coriolus
Orange Belt

Please log in to comment
0
In addition to the ALLUSERS=1 property (as noted by Coriolus above) you'll need to insert CreateFolder and Directory entries in the Directory /CreateFolder tables, unless you've already got files installing to that directory.
Answered 12/05/2007 by: aogilmor
Ninth Degree Black Belt

Please log in to comment
0
The ALLUSERS property is irrelevant here.You are almost certainly falling over the (well-known to experienced packagers) "feature" in WPS where it completely ignores the All Users profile location. Heaven only knows when they'll fix this nonsense.I reported it in 5.6 and we're at 7.1 so I for one am not holding my breath.

If you have an InstallShield MSI handy, you can rip the relevant Custom Actions straight out and patse them into your project. Make sure you add them to the UI and EI sequences, to ensure that silent installs (which don't run the UI) install correctly. The CAs you're interested in look like this:

If VersionNT then
Set Property USERPROFILE to [%USERPROFILE]\
End
If VersionNT =400 then
Set Property ALLUSERSPROFILE to [%SystemRoot]\Profiles\All Users\
End
If VersionNT >= 500 then
Set Property ALLUSERSPROFILE to [%ALLUSERSPROFILE]\
End

Of course, if you don't have a handy MSI, you can use the above as a clue as to what you need to do. As I say, just make sure you add these to both sequences.

Lastly, add them to your Windows Application template because this *will* bite you again. It's one of the first things I do when I go to a new client.
Answered 12/05/2007 by: VBScab
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity