I have my package just how I need it, with one exception that has me tearing my hair out:

How do you get rid of the initial nag screen when you start up QuickTime that says, "Some of the file types associated with QuickTime applications are currently associated with other applications. Should I restore these file type associations to QuickTime?" and has the "Do not ask to perform this check again" checkbox at the bottom.... yes/no.

I am deploying this to XP and Win7 machines, and the nag screen only comes up on Win7 machines. Apparently this setting is not included in the qtp or xml preference files, nor can I find anything of value in a snapshot of the launch. It appears for every new user who logs on to the machine.

Any and all suggestions welcome! Thanks in advance.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
I can tell you the trouble shooting method for this.

Record the changes by using the tool Picture Taker by launching the shortcut and checking the box do not perform "Do not ask to perform this check again". You may get some xtra reg keys or some inputs in ini file or whatever. You include this changes in your package.
Answered 05/10/2011 by: naveen.packager
Green Belt

Please log in to comment
0
He's done that already:

nor can I find anything of value in a snapshot of the launch.

I found this in the knowledgebase - http://www.appdeploy.com/packages/detail.asp?id=520

To ensure that the dialog box doesn't appear again you need to add the following registry key
[HKEY_CURRENT_USER\Software\Apple Computer, Inc.\QuickTime]
"LastFileAssociationCheck"=dword:07658000

This is a Hex value and when added to the mst through Wise I had to give it a the Binary value of 124092416, Double Word. When installed this value gets installed as the Hex value stated above (07658000).
Answered 05/10/2011 by: timmsie
Fourth Degree Brown Belt

Please log in to comment
0
ohh I am sorry I did not read it properly.
Answered 05/10/2011 by: naveen.packager
Green Belt

Please log in to comment
0
Hi Lori,

There is a file QuickTime.qtp which is created at runtime in C:\Documents and Settings\USER\Local Settings\Application Data\Apple Computer\QuickTime when launched quicktime player, and this should be afftecting the launch screen.

when u go to edit-->preferences-->quick time preferences-->File types Tab, below there is a check box and i think this the one we need to manage here.

Manually uncheck that and record the changes, then you can get the changed QuickTime.qtp, include that in your package.

This is for Windows XP and hope the same with Windows 7.

Hope this helps.
Answered 05/10/2011 by: naveen.packager
Green Belt

Please log in to comment
0
Unfortunately, the reg key (which I also found) does not work in Windows 7. I've tried searching the registry from an install for that key, but nothing shows. The qtp file does not store this information in Windows 7, either. Hence, the hair tearing out. :)

When you go into QuickTime on Windows 7 to try to change file associations, it takes you to the Windows Control Panel to make the changes there. Not in QT anymore.

Windows 7 is making me grumbly. Ok, Windows 7 + Apple. Still not finding how to suppress this nag screen on first launch!
Answered 05/10/2011 by: greenjelloland
Senior Yellow Belt

Please log in to comment
0
Lori,

I had a quick look at the package we made here recently and I found the following:

The regkey is in there under HKEY_CURRENT_USER\Software\Apple Computer, Inc.\QuickTime\LastFileAssociationCheck
Has a value of 124354560 or hex:7698000 in our package.

The Quicktime.qtp file it seems HAS TO BE under the LocalLow folder of the user's AppData, not either of the other two, Local or Roaming
Make sure a repair or self heal actually puts the qtp file in the correct location in the user's profile, cause our packager here had some problems with this.

Kind Rgds,

PJ
Answered 05/10/2011 by: pjgeutjens
Red Belt

Please log in to comment
0
I tried the registry key again (like for the 4th time), and it finally worked. Go figure.

Thanks, everyone!
Answered 05/10/2011 by: greenjelloland
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity