A frustrating re-occurance when repackaging (I am using Wise), is the error 1904, Module xxxx failed to register. If I run the MSI manually, I can hit ignore and continue on. Is there any way to auto-ignore these errors? I know I can go in and fix each one, but it is a pain and it is an ongoing problem. [:@]
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Delete .dll or .ocx from selfregister table. And add it as a file.
Answered 06/06/2007 by: ogeccut
Black Belt

Please log in to comment
0
I know I can go in and fix each one but this happens frequently when I do a snapshot, and some files need to be registered.

I was just asking if anyone knew of a way to suppress the error when it fails to register a file during the msi install.
[8|]
Answered 06/06/2007 by: MicrosoftBob
Blue Belt

Please log in to comment
0
Hi Bob,
this is a test and debug job each of us has to do, i suppose.
Load the Package in Wise, make sure you are in 'Installation Expert' and select the file in question.
Select 'Details', go to the 'Self-Registration' tab and make sure 'Do not register' is selected.
Regards, Nick
Answered 06/07/2007 by: nheim
Tenth Degree Black Belt

Please log in to comment
0
How depressing. I was hoping for a way to avoid that. [:'(]
Answered 06/07/2007 by: MicrosoftBob
Blue Belt

Please log in to comment
0
Hi Bob,
are you kidding? Software, that trows errors, normally doesn't this without a reason!
If you are not willing to debug your own work, make sure no one else is depending on this stuff!
Just can't understand such an attitude.
Regards, Nick
Answered 06/07/2007 by: nheim
Tenth Degree Black Belt

Please log in to comment
0
I would agree with you except in a situation like this. Some DLLs can't be registered, thus the (non-fatal) error. So what do we do to fix it? We go in and tell it not to register! Well, that is the same thing as ignoring that it couldn't be registered!

- Bob
Answered 06/07/2007 by: MicrosoftBob
Blue Belt

Please log in to comment
0
Hi Bob,
this is just not true.
There are a lot of DLL's out there, which do not contain stuff to register.
Nobody is trying to register such components.
Regards, Nick
Answered 06/07/2007 by: nheim
Tenth Degree Black Belt

Please log in to comment
0
Perhaps I'm misunderstanding you...this is the situation...

I do a snapshot of an application install and generate an MSI file. When I run this MSI file on a test workstation, I get the error "Module xxx.dll failed to register", to which I can click ignore, and continue the install. I do what you described above and select "Do not register" and generate a new MSI. Then it installs on the test workstation without the error because it doesn't try to register the DLL. Well, that is the same as clicking ignore, in my opinion. In both cases, it does not register the DLL.
[sm=rolleyes.gif]
Answered 06/07/2007 by: MicrosoftBob
Blue Belt

Please log in to comment
0
First of all I wouldn't use the self registration (SelfReg table), even Microsoft doesn't recommend this.
Make sure to capture these into the Registry table or/and the advertise related tables.

I know that Wise Package Studio some times adds DLLs to be registered even though they doesn't support to be registered.

In my opinion, clicking Ignore isn't the same thing as preventing them from being registered, you just tell the installation to go ahead with the installation anyway.
Answered 06/07/2007 by: AngelD
Red Belt

Please log in to comment
0
How do I choose to not use the self registration (SelfReg table)? I'm not familiar with that option.

Why does Microsoft recommend not to use the SelfReg table? Is it because of problems like this?

Changing a DLL to not register versus clicking ignore produces the same result -- the DLL does not register.
Answered 06/07/2007 by: MicrosoftBob
Blue Belt

Please log in to comment
1
To prevent DLLs from being added to the SelfReg table:
Select Options from the Tools menu
In the Advertising tab uncheck the "Automatically add self-registration" checkbox

Changing a DLL to not register versus clicking ignore produces the same result -- the DLL does not register.
Yes they produce the same result.
But you're ignoring an error that shouldn't be there in the first place, right?

Have a look at Rule 19: Avoid Using the SelfReg Table
Tao of the Windows Installer, Part 2
Answered 06/07/2007 by: AngelD
Red Belt

Please log in to comment
0
Thanks, I'll try unchecking that option.

Since it looks like this SelfReg table has all these inherent problems, one wonders why Microsoft even included it, and what advantages it has, if any.

>> But you're ignoring an error that shouldn't be there in the first place, right?
Call me lazy if you want, but it just got to be extremely irritating to "fix" yet another MSI package. [;)]
Hopefully, this option will be an easy way to prevent the problem from happening in the first place.
Answered 06/07/2007 by: MicrosoftBob
Blue Belt

Please log in to comment
0
I guess Microsoft had it there for a quick and dirty way to register COM components such as DLL and OCX files.
Answered 06/08/2007 by: AngelD
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity