anybody ever packaged olympus dss player using an answer file? . The problem i have is that this application creates the answer file , but when i try to use that same answer file to install silently it pops up with a dialog asking for the serial number. Is there anyway i can add the serial number in a command line or right into the answer file so i can pass this dialog?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Hi justinSingh,

Can you provide more info about the installer? Is it msi or setup.exe?

In my experience in the past, when performing a silent/limited GUI install with an MSI, it does not reference an answer file/setup.ini file. You can try to add the information to the Property table of a MST and see if it passes through to the installer.

And you should also consider adding a property for limiting the GUI - (LIMITUI=1) - if you don't limit the GUI, it will always prompt for Next/Serial #/User/Company/etc, even if you have them set in the Property table...
Answered 03/30/2007 by: JdotQ
Senior Purple Belt

Please log in to comment
0
the installation is a setup.exe and it's packaged using installshield, but there is no .msi being extracted to the temp folder or any where on my pc. I have posted below the answer file i get , please let me know if i can input the my information some where.



[InstallShield Silent]
Version=v6.00.000
File=Response File
[File Transfer]
OverwrittenReadOnly=NoToAll
[{76E6BBAA-25E6-4BFC-9613-75A5CACE2940}-DlgOrder]
Dlg0={76E6BBAA-25E6-4BFC-9613-75A5CACE2940}-SdWelcome-0
Count=8
Dlg1={76E6BBAA-25E6-4BFC-9613-75A5CACE2940}-SdLicense-0
Dlg2={76E6BBAA-25E6-4BFC-9613-75A5CACE2940}-SdAskDestPath-0
Dlg3={76E6BBAA-25E6-4BFC-9613-75A5CACE2940}-SdConfirmNewDir-0
Dlg4={76E6BBAA-25E6-4BFC-9613-75A5CACE2940}-SdSelectFolder-0
Dlg5={76E6BBAA-25E6-4BFC-9613-75A5CACE2940}-SdStartCopy-0
Dlg6={76E6BBAA-25E6-4BFC-9613-75A5CACE2940}-AskOptions-0
Dlg7={76E6BBAA-25E6-4BFC-9613-75A5CACE2940}-SdFinish-0
[{76E6BBAA-25E6-4BFC-9613-75A5CACE2940}-SdWelcome-0]
Result=1
[{76E6BBAA-25E6-4BFC-9613-75A5CACE2940}-SdLicense-0]
Result=1
[{76E6BBAA-25E6-4BFC-9613-75A5CACE2940}-SdAskDestPath-0]
szDir=C:\Program Files\Olympus\DSSPlayer
Result=1
[{76E6BBAA-25E6-4BFC-9613-75A5CACE2940}-SdConfirmNewDir-0]
Result=1
[{76E6BBAA-25E6-4BFC-9613-75A5CACE2940}-SdSelectFolder-0]
szFolder=Olympus DSS Player
Result=1
[{76E6BBAA-25E6-4BFC-9613-75A5CACE2940}-SdStartCopy-0]
Result=1
[{76E6BBAA-25E6-4BFC-9613-75A5CACE2940}-AskOptions-0]
Result=1
Sel-0=0
Sel-1=0
Sel-2=0
[Application]
Name=Olympus DSS Player Version6
Version=6.00.0000
Company=Olympus
Lang=0009
[{76E6BBAA-25E6-4BFC-9613-75A5CACE2940}-SdFinish-0]
Result=1
bOpt1=0
bOpt2=0
Answered 03/30/2007 by: justinSingh
Blue Belt

Please log in to comment
0
justinSingh,

Have you attempted to repackage the exe into an MSI (with AdminStudio/Wise/etc)?

I am not sure how to pass that information from the answer file along with only a setup.exe-type installer...

If you are able to repackage the exe into an MSI, you could possibly have some good luck putting those values in the Property table...
Answered 03/30/2007 by: JdotQ
Senior Purple Belt

Please log in to comment
0
justinSingh,

In your answer file under the heading [Application] try the entry SERIALNUM= {Enter your serial number here}.

I am not guaranteeing this to work but it has worked for me in other Installsheild installs.
Answered 03/30/2007 by: Cygonz
Senior Yellow Belt

Please log in to comment
0
I am packaging right now DSS Player PRO. I've searched a lot and at last found the answer.
You have on the CD, the directory TOOLS. Just run LICDATTL.EXE and put the correct serial number.
This will create a file Licence.dat. Put this file in the your setup directory with the ISS File and everything will work silently.
Answered 04/05/2007 by: simonlebrun
Yellow Belt

Please log in to comment
0
I am seeing the same issue here... it is not recording the username & serial number.

justinSingh - did you find a way round to this? If so, how did you find a way round to this?

Thanks,
Answered 08/20/2007 by: tsutton
Orange Belt

Please log in to comment
0
I wasn't able to get around this problem so i gave up and just captured it.
Answered 08/21/2007 by: justinSingh
Blue Belt

Please log in to comment
0
Hello Justin,

A similar problem was faced by me, when i tried to package PGP 8.1 application. What you can do is, give the license wherever it asks and just check if it stores a license file or something of that sort either on the file system or in the registry.

I understand some packages can prove to be a real pain specially when logical things stop working. I totally agree with your approach in this regard. However, just give it a shot if it helps.

With Best Regards,
Tushar Singh
Answered 08/24/2007 by: matrixtushar
Purple Belt

Please log in to comment
Answer this question or Comment on this question for clarity