I have repackaged IBM iSeries Access for Windows into a MSI. My install for the most part seems to work well. However, after deploying via a GPO in AD the following message is displayed when a non-admin user logs onto the machine:

"An administrator must log on after restarting Windows in order for iSeries Access for Windows install to complete successfully."

Once a user with admin rights logs on this will go away. However, even if an admin doesn't and a normal user logs on the program works - so I'm not sure what it thinks needs to be done that requires admin rights. Is there anyway to find out or to disable this? Or a workaround for the auto-install to accomplish whatever it wants done? I had tried to insert a ForceReboot into the sequence thinking that might help, but didn't seem to have any luck actually getting the install to resume from the reboot (I got stuck in an endless reboot cycle).

FYI, I am using AdminStudio from InstallShield to edit the MSI.

Thanks,
-Heath
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Install it manually, then run the repackager snapshot, then reboot and log in as admin, then run the repackager again after to see what it is doing as admin, then if need be edit the snapshot data and export the settings, then repackage the initial install and then add the components from the other snapshot to the same msi. Might be worth a shot.
Answered 08/31/2004 by: cdupuis
Third Degree Green Belt

Please log in to comment
Answer this question or Comment on this question for clarity