I have a handful of servers that are not checking in to Kace. I've gone through all of the usual troubleshooting, but cannot get it to work correctly. I get an "(302) Unknown error" when running runkbot 4 0 from CMD line. I've only found one post with that error, and it was never answered. 

I noticed my amp_auto.conf webport was set to 80 while my working servers are still set to 443. When I run "C:\Program Files (x86)\Dell\KACE\AMPTools.exe" host=kbox.domain.edu it will change the webport back to 443. At that time I can run runkbot 4 0, and the machine will inventory successfully. After that inventory though it will revert back to webport=80. I can repeat the process by resetting the conf file, and it will work every time. I just never sticks.  

I have port 80 redirecting to 443 in settings. I can ping, traceroute, and access the kbox via the web both http, and https on the machine. I was curious if anyone has ever seen anything like this?
4 Comments   [ + ] Show Comments

Comments

  • We are not seeing that, but I remember you have multiple kbox's with certs we only have one.
  • It looks to have something to do with Epic Hyperspace. These are Citrix servers that we test Hyperspace patches on. They sent us a bad patch, and we had to uninstall it via command line. It doesn't appear to play nicely with Kace. We're still trying to find a solution, but at this point at least we have it narrowed down.
    • finding the cause can be the hardest part
  • I installed the 5.5.30275 agent to test on a server, and it works as it should. When I update the agent back to 6.4 it continues to fail. Downgrade again, and it works. Hopefully support can shed some light on this.
  • I've disabled every non windows service. The 5.5 agent works just fine. If I install anything higher than that it will change the amp file to port 80 every time.
Please log in to comment

There are no answers at this time

Answers

Answer this question or Comment on this question for clarity