Hello All, I am working the current K1000 agent 5.4.10 and I have noticed the agent just stops talking after some of my system reboots.

Has anyone else sees this?

THe only way I have been abel to resolve it is to use the agent installation to remove the old one and all the files. THen I have a reg file I run to remove the Reg Keys.

Then I reinstall and it will work for a while but I have seen the issue return.

Any info or diagnostics I might try would be greatly appreciated

Thanks

2 Comments   [ + ] Show Comments

Comments

  • check if the agents are running or not. I've seen it multiple times that the agent shut down for some reasons (usually caused by some sharp toothed antivirus and firewall software) If so, it should be seen in the logs. Then exclude the KACE files from this software or if you too lazy ;) simply write a script to restart the ampagent regulary
  • I plan to go to the security to to review the antivirus. I am curious can you tell me how to pull the agent logs? Also do you have a sample of the Script?
    • See below to enable logs and for AV exclusions. To start/restart the agent (assuming Windows) would be something like "net start ampagent": http://technet.microsoft.com/en-us/library/cc736564%28v=ws.10%29.aspx

      or:

      "c:\program files (x86)\dell\kace\amptools restart"
Please log in to comment

Answers

4

How to enable debug: http://www.kace.com/support/resources/kb/article/how-to-enable-debug-logs-on-the-kace-k1000-client-kbox-client-deployment

You can try to have it force inventory: http://www.kace.com/support/resources/kb/article/how-to-force-a-client-check-in-outside-the-normal-run-interva

Whitelist/AV exclusions:

http://www.kace.com/support/resources/kb/article/What-directories-registry-and-executables-do-I-need-to-whitelist

http://www.kace.com/support/resources/kb/article/K1000-Whitelist-of-URLs-and-file-exts-for-Patch-Downloads

Answered 08/15/2013 by: jknox
Red Belt

  • Jnox, Thank you for the information, I have reviewed and whitelisted the information in my environment. I would not have even thought about my AV but it corresponds to the dates the agents stopped working. I will advise next week to see if the problem continues. Does anyone know how to completely remove the agents and all files associated with the agent via gpo?
  • You gotta be kidding me - implicitly *trust* C:\Windows\Temp? (first link under Whitelist/AV exclusions) That's the LEAST trusted location on my network!
Please log in to comment
Answer this question or Comment on this question for clarity