I can't get clients to check in all of a sudden after installing the agent. I'm still having issues with the K2000 installing the agent as a post-install task for some reason, but even after manually running the MSI (renamed with the kbox hostname at the end of the MSI), it doesn't check in.


Reading the AMP.conf file, it's missing all sorts of info. Do I need to install the MSI special somehow for SSL or x64 systems? I'm having issues with 10 machines in 2 different locations. I install it like every other machine, but they aren't checking in.


Recently updated to 5.4.5315 and enabled SSL as well. We don't have port 80 forwarded to 443 yet, so it should be able to connect to SSL or non-SSL, but it doesn't seem to connect (or fill out the right info for that matter). It seems as if ever since we updated to 5.4.5315, enabled SSL, and updated the K2000 to the latest version, we are having issues all over the place with getting the damn agent to work/install correctly.





0 Comments   [ + ] Show Comments


Please log in to comment




You may be missing the SSL Intermediate Certificate, this goes together with the resto of the items (SS Cert and Private Key). We had that same issue 2 yrs ago.

About the port fowarding (80 to 443), you can enable it, just do not uncheck yet the option: "Enable port 80 access" until the agents check-in is solved.

Good Luck!

Answered 02/26/2013 by: horacior
Third Degree Blue Belt

  • The intermediate was installed with the other certificate. Do you mean the client machine is missing it? I'm at a loss here as to why it's not installing/checking in correctly.
Please log in to comment

If you install the agent manually with the same command used in the post install task, does the agent install properly and does that system check in?

Another way to set up a post install task with the agent installer is to use the installer as is (without renaming it) and to use the command line of the post install task to set the host name.  Something like this:

For the systems that aren't checking in, access that machine and run this in a command prompt (assuming Windows):

  • cd c:\program files (x86)\dell\kace
  • ampagent.exe -host=YOUR_K1_HOSTNAME

 That should set the host and have the client system check into the K1000.

Answered 02/26/2013 by: jknox
Red Belt

  • Thanks - I'm actually trying this process (HOST=) right now. It worked fine with this being the only post-install task, so now I'm trying it with all the other post-install tasks to factor our a compatibility issue with order/software.
Please log in to comment
Answer this question or Comment on this question for clarity