I have success installing Adobe Reader 7 via Group Policy. However this method leaves all pdf documents with an unassociated icon (generic doc icon). The documents will open when double-clicked and all associations are correct.
I've tried manually changing the icons through folder options, Checked registry keys, etc. Everything appears correct, and changing associations then changing them back to the correct thing does nothing.

When I run the exact same .msi with the same .mst transforms everything works, including the icons showing up correctly. The problem only occurs when installing via Group Policy.

I've used several different packages with different transforms.
I've installed automatically and just published the package.

Has anyone faced this problem and solved it?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Check whether these icons are advertised! since that's what I can make out right now. Also go through the following article for more info on Assigned and published and how they make your package different Assigned/Published
Answered 04/03/2006 by: wiseapp
Second Degree Green Belt

Please log in to comment
0
Thanks for help, but the article didn't have anything I don't already know.

I have found that whenever I Assign the package to users there is no icon in the start menu to click for installation. According to all documentation I have read, when Assigning a package to the User an icon/shortcut for the program should be in the Start Menu. Clicking this shortcut or an associated file (like a pdf) will install the program then.
Answered 04/04/2006 by: Bionicjoe
Yellow Belt

Please log in to comment
0
[font="courier new"]If you're wiling/able to modify your MST file, find the "Registry" table and make the following changes on each entry that has a Root=0 and modifies a "DefaultIcon" registry value.
[font="courier new"]
[font="courier new"]Default Value: [WindowsFolder]Installer\[ProductCode]\PDFFile_8.ico,0
Revised Value: [INSTALLDIR]Resource\Icons\PDFFile_8.ico,0
[font="courier new"]
[font="courier new"]More information:
The installer creates a duplicate set of icon files in two locations.
• Location#1 is [INSTALLDIR]Resource\Icons\
• Location#2 is [WindowsFolder]Installer\[ProductCode]\
However, in a Per-User install (which happens with published-to-user GPO), the icons are created in [%APPDATA%]\Microsoft\Installer\[ProductCode] in the Current Users profile instead. However, the icons are not pointed to this new locaiton automatically. This causes the problem where generic icons will be displayed where you should see PDF icons.
[font="courier new"]My solution was to point the icons to the static location under [INSTALLDIR].
[font="courier new"][font="courier new"]
[font="courier new"]NOTE: I've not tested the impact of this change on ASSIGNED-to-USER, ASSIGNED-to-COMPUTER, ADVERTISED, or Manual install. I only made this mod for a GPO to user scenario. But it seems to work for our environment.

Answered 07/22/2008 by: controlair
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity