I apologize in advance if this has already posted or discussed as I have been unable to find a subject on this. With that said, I am trying to uninstall Adobe InDesign CS3. Now I have been able to install it successfully with the install.xml file but my uninstall.xml file is not working. Here is what my uninstall command looks like:

"\\va1wps01\Unpackaged Applications\Adobe Indesign CS3 - OD&T\Adobe CS3\Setup.exe" --mode=silent --deploymentFile="\\va1wps01\Unpackaged Applications\Adobe Indesign CS3 - OD&T\Adobe CS3\uninstall.xml"

This looks exactly the same as my install xml file except my install file is called install.xml.

Can anyone tell me why this uninstall could be failing? By the way, I receive an Exit code: 7 when trying to uninstall.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
From memory (sorry!), DOS error 7 is 'Memory control blocks destroyed'. I think the installer simply crashed. ProcMon should be able to help you determine what's going on.
Answered 05/08/2008 by: VBScab
Red Belt

Please log in to comment
0
I thought these errors were Adobe specific and not pertaining to DOS. Taken from the Adobe deployment white paper:
[left]Exit code: 7 Unable to complete silent workflow.[/left]
Answered 05/08/2008 by: dpolishsensation
Blue Belt

Please log in to comment
0
OK, I stand corrected.

And , BTW, what a vision of clarity Adobe's message is...

And still ProcMon will show you what's happening. :)
Answered 05/08/2008 by: VBScab
Red Belt

Please log in to comment
0
I was finally able to uninstall it. I had to close out of all applications and it finally came back with an error code: 0 Great success!! No kudos to Adobe for their package!
Answered 05/08/2008 by: dpolishsensation
Blue Belt

Please log in to comment
Answer this question or Comment on this question for clarity