I have a problem with uninstalling Adobe Illustrator if I have applied one or more transform files. It wont uninstall from neither Add/Remove Programs of through Group Policy.

I just get an error saying that Removal failed.

I ran "msiexec /x <package> TRANSFORMS=<transformfile.mst> /l*vx" and this is the end of the output:

Property(S): ROOTDRIVE = C:\
Property(S): WinSxS = C:\WINDOWS\
Property(S): WWWROOT = C:\
Property(S): ProfilesFolder = C:\WINDOWS\
Property(S): GAC = C:\
Property(S): CostingComplete = 0
Property(S): OutOfDiskSpace = 0
Property(S): OutOfNoRbDiskSpace = 0
Property(S): PrimaryVolumeSpaceAvailable = 0
Property(S): PrimaryVolumeSpaceRequired = 0
Property(S): PrimaryVolumeSpaceRemaining = 0
MSI (s) (0C:DC) [10:07:38:030]: Note: 1: 1725
MSI (s) (0C:DC) [10:07:38:051]: Product: Adobe Illustrator CS2 -- Removal failed.

MSI (s) (0C:DC) [10:07:38:061]: Attempting to delete file C:\WINDOWS\Installer\1c6b9e.mst
MSI (s) (0C:DC) [10:07:38:061]: Unable to delete the file. LastError = 32
MSI (s) (0C:DC) [10:07:38:071]: Cleaning up uninstalled install packages, if any exist
MSI (s) (0C:DC) [10:07:38:071]: MainEngineThread is returning 1603
MSI (s) (0C:D4) [10:07:38:081]: Destroying RemoteAPI object.
MSI (s) (0C:7C) [10:07:38:081]: Custom Action Manager thread ending.
=== Logging stopped: 12.07.2006 10:07:38 ===
MSI (c) (D0:A0) [10:07:38:593]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
MSI (c) (D0:A0) [10:07:38:603]: MainEngineThread is returning 1603
=== Verbose logging stopped: 12.07.2006 10:07:38 ===

Any suggestions?

0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.



did you try the sequence from the HKLM/Software/Windows/CurrentVersion/Uninstal/<package name>

in our Installation the key for adobe illustrator cs2 sounds like msiexec /i {b2f5d08c-bla-bla}

using msiexec /x {that-string} and Illustrator was gone with no errors.

Answered 07/12/2006 by: laszlo
Senior Yellow Belt

Please log in to comment
I have tried all the steps from Adobe support (http://www.adobe.com/support/techdocs/331841.html).

I have tried to install with different types of transform files, but all with the same result. If I install without and transformfile and enter the serial manually it works fine, but I cant manually install the application on a few hundered computers.
Answered 07/12/2006 by: hovelsj
Senior Yellow Belt

Please log in to comment
I'm not sure I'm following what is going on here. Are you trying to uninstall it or install it? You said uninstall in the first message but install in the second one.

If you're trying to install it, you shouldn't be using an MST to put in the serial number. According to the document you linked, you're supposed to make all of your changes via the setup.exe not the msi directly.

That being said, I changed the Abcpy.ini with my company name and serial number, called the MSI with a transform and haven't had any issues.
Answered 07/12/2006 by: Rhys
Orange Belt

Please log in to comment
Finally I found out what was wrong. If I created an mst with Wise - it installed, but woudnt uninstall. I created the mst with orca and edited it with Wise and it worked perfectly. I dont know what Wise did wrong, but it didnt create the mst correctly. Though,- orca did:)
Answered 07/12/2006 by: hovelsj
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity