Why is it necessary to add mms.cfg file to disable autoupdate can't we do the same through adding property in mst
AutoUpdateDisable=1


Please let me know
Can't it be done this way?

Thanks & regards,
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
I'd have to take a wild guess - would you rather install software by clicking on an msi file, or by typing in a command line with a TRANSFORMS=...? Plus AutoUpdateDisable doesn't look like a public property, but that's besides the point...
Answered 12/26/2008 by: revizor
Third Degree Blue Belt

Please log in to comment
0
No, you're confusing a Windows Installer property with an "element" in the .cfg file. Just add the .cfg file to your installation. See this link for how to do it:
http://kb.adobe.com/selfservice/viewContent.do?externalId=16701594
Answered 12/26/2008 by: aogilmor
Ninth Degree Black Belt

Please log in to comment
0
Hi,

It happened to experience with Flash 9.0.124 where .cfg file was not working to disable the autoupdates. Why was it not working I did not understand, then we have choosen the other option of copy settings.sol file to user profile.

Regards
Ramesh
Answered 12/30/2008 by: ramesh111k
Purple Belt

Please log in to comment
0
helluva lot harder to dist files to all user profiles than have the cfg file in the flash dir. I'd rather find out why it's not working and fix it. Like the guy on SNL news says, FIX IT by FIXIN' IT! [:D]
Answered 12/30/2008 by: aogilmor
Ninth Degree Black Belt

Please log in to comment
0
Like the guy on SNL news says, FIX IT by FIXIN' IT! [:D]WHAT?!? When it's SOOOOOOOO much easier to botch it up? LOL. HNY, Owen. Keep postin' and try to stay sane.
Answered 12/31/2008 by: VBScab
Red Belt

Please log in to comment
0
ORIGINAL: VBScab
Like the guy on SNL news says, FIX IT by FIXIN' IT! [:D]WHAT?!? When it's SOOOOOOOO much easier to botch it up? LOL. HNY, Owen. Keep postin' and try to stay sane.

You have a happy new year too. Hopefully we'll have a year full of FIXIN' IT and other more enjoyable pursuits. [:D] LOL...
Answered 12/31/2008 by: aogilmor
Ninth Degree Black Belt

Please log in to comment
0
Hi Ramesh,
are you aware of the requirement, that the file should be in UTF-8 format?
See the document under the link that Owen posted above.
And its not so easy to test it. See: http://itninja.com/link/adobe---player-licensing
Version 10 seems to be not so strict about UTF-8, but i wouldn't stress it...
Regards, Nick
Answered 01/02/2009 by: nheim
Tenth Degree Black Belt

Please log in to comment
0
Hi nheim,

Yes, the file was in UTF-8 format but still it was not working.

regards
Answered 01/04/2009 by: ramesh111k
Purple Belt

Please log in to comment
0
You know what you need to do:

FIX IT!!!

How...?

by FIXIN' IT!
Answered 01/04/2009 by: aogilmor
Ninth Degree Black Belt

Please log in to comment
0
To be fair, although the solution is documented here on AppDeploy, you have to wonder about the intelligence of that document's author when they make this statement:3. Save the mms.cfg file with UTF-8 encoding in the correct system location for the user's operating system. without any sort of clue as to what those locations are. I mean, how hard would it be to enumerate those locations, given the limit target of the product itself?

EDIT:
I take that back. The text above what I quoted does tell you where the file is supposed to live. Now I can switch my rage to how Adobe thinks this nonsense is valid for corporate deployments. Why not add the AutoUpdate option to a dialog/public property and handle it appropriately?
Answered 01/05/2009 by: VBScab
Red Belt

Please log in to comment
0
Hi,

Let me explain what I did and correct me if anywhere i did mistake bcoz I am not able to get why autoupdates is still enabled eventhough it is a simple thing of copying the mms.cfg file.
1. I installed Flash 10 and checked the autoupdates is enabled (link:http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager05.html)
2. I have created mms.cfg with the entry AutoUpdateDisable=1
under C:\WINDOWS\system32\Macromed\Flash\ and saved with UTF-8 encoding as our's is Windows XP.
3. I again checked the above link (http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager05.html)
Still the option of "Notify me when an update to Adobe Flash Player is available" is enabled.

Regards
Ramesh
Answered 01/05/2009 by: ramesh111k
Purple Belt

Please log in to comment
0
Use ProcMon to dynamically show you whether or not the MMS.CFG file is being updated when you toggle that setting on and off. I'm willing to bet that it isn't. If not, the file which IS being updated will be [AppDataFolder]Macromedia\Flash Player\macromedia.com\support\flashplayer\sys\settings.sol
Answered 01/05/2009 by: VBScab
Red Belt

Please log in to comment
0
Hi Ramesh,
this link is a dead end! It will always show this settings.
The only way to make sure, its disabled is to sniff.
See: http://kb.adobe.com/selfservice/viewContent.do?externalId=16701594&sliceId=2
Or use the method described by "MicrosoftBob" here: http://itninja.com/link/adobe---player-licensing

Regards, Nick
Answered 01/05/2009 by: nheim
Tenth Degree Black Belt

Please log in to comment
0
So......the config file doesn't get updated dynamically to reflect the status quo? Yet more awesome software from Adobe...
Answered 01/05/2009 by: VBScab
Red Belt

Please log in to comment
0
Hey Ramesh, I saw that link and I think like nheim says it's dead - at least let's hope that my setting wasn't changed simply by virtue of visiting the web site. though, you never know with adobe [:D] could test by using a downlevel 9x version and seeing if you can get it to prompt you for a newer version. if it does that would mean the mms.cfg method of stopping updates is broken and should be reported to adobe.
Answered 01/05/2009 by: aogilmor
Ninth Degree Black Belt

Please log in to comment
Answer this question or Comment on this question for clarity