Hi,

I am trying to set up a custom Machine Action for Kace 5.5

I want to create an entry to connect directly to the computer managament console of a remote machine.
I try in command promt and it works with: "compmgmt.msc /computer=\\<ComputerName>". This will open the computer management console of the remote computer.
 
Only, I have difficulties to get it to work in the Kace.
I tried with adding a custom action "compmgmt.msc /computer=\\KACE_HOST_NAME"
Also "compmgmt.msc /computer=\\KACE_HOST_IP" doesn't work...
 
I alwwat get the error "Invalid URL. Please check the Machine Action and try again."
 
I already set "Initialize and script ActiveX controls not marked as safe for scripting" to "Enable" in the "Security Settings " for the "Trusted Sites Zone", as mentioned in this post:
http://www.itninja.com/question/adding-a-new-action-on-kace-5-4-for-services-msc-on-a-remote-computer-will-not-work
 
Can anyone find me the correct syntax please?
Answer Summary:
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

1

Ok, I found it myself...

Thanks to http://www.itninja.com/blog/view/k1000-5-4-machine-actions

cmd.exe /c compmgmt.msc /Computer:KACE_HOST_NAME

This worked perfectly.

But still one question: I would like to add a "Run-as" command. Can't figure out how to do it...

Answered 01/09/2014 by: torgal
Orange Senior Belt

Please log in to comment
1

Found it again, faster than you guys...

cmd.exe /c runas /user:<domain>\<user> "mmc compmgmt.msc /Computer=\\KACE_HOST_NAME"

Answered 01/09/2014 by: torgal
Orange Senior Belt

Please log in to comment
Answer this question or Comment on this question for clarity

Share