I am trying to add a new 'action' for inventory items, that is, opening the SERVICES for Remote Computers.
From DOS, this is done using : c:\windows\system32\services.msc /computer=<computername>

When i add this into a Custom Action in KACE : "c:\windows\system32\services.msc" /computer=KACE_HOST_NAME

it does not work, i get the message : Invalid URL, Please check machine action and try again.

I have other custom actions working fine, but this one does not work...what am i missing ?

Answer Summary:
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

3

Hi guys,

A small action plan on "creating a custom machine action to open a remote services MMC":

1. Add the K1000 webUI to the "Trusted Sites" in IE (tested with IE9)

2. Set up Internet Explorer and custom machine action

a) Even though the site is trusted, we require to accept a security prompt for running scripts and ActiveX element. Go back to "Trusted Sites" and modify the default securit level. You may keep the default (medium) settings but the following change should be fone for convenience, setting it just to low will allow execution but presents a popup, the following disables the popup and does the main magic:

"Enable" > "Initialize and script ActiveX controls not marked as safe for scripting"

Example:

b) The machine action command line should look as follows:

cmd.exe /c services.msc /Computer:KBOX_HOST_IP

3. Test it and let us know if it works for you too

 

Cheers,
Rasko

Answered 12/06/2012 by: RaSko
Purple Belt

Please log in to comment

Answers

1

try it with this

"c:\windows\system32\services.msc" /computer=$(KACE_IP_ADDRESS)

Answered 12/05/2012 by: SMal.tmcc
Red Belt

Please log in to comment
1

Hello Rasko,

Point 1 and 2 where already in place (other actions work fine) :-)

Using the cmd.exe is indeed a method i did not try.

I made it like this now :

cmd.exe /c services.msc /Computer:KACE_HOST_NAME

(alternative is KACE_HOST_IP) but i like to see the hostname in services).
KBOX_HOST_IP did not work, but KACE_HOST_NAME does :-)

Tested it on Kace 5.4, all works fine now ! :-)

Thanks RaSko :-) !

Answered 12/07/2012 by: Wiljoh
Senior White Belt

Please log in to comment
0

Hello SMall.tmcc,

Nope, does not work either...does that work for you ? Because if it is, it is perhaps something on my PC...however, i did try it on several other PC's as well (x64, x32 (Win7))

 

Answered 12/06/2012 by: Wiljoh
Senior White Belt

Please log in to comment
Answer this question or Comment on this question for clarity