So I have created this .msi to serve only one purpose, run Active Setup.  INSTALLDIR is setup to user profile.  This runs and works fine, but I see that in registry under HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\{GUID} the Install Location always shows my profile location instead of current user’s profile location.  Any thoughts on how can I change it to current user’s profile.


Thanks,

AK

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

0
Since your MSI isn't actually installing anything, you can set INSTALLDIR to be a system folder or something, if it bothers you that much. Personally, I wouldn't bother but then I wouldn't go to the trouble of creating an MSI just to populate a few registry entries, either.
Answered 04/12/2016 by: VBScab
Red Belt

  • I forgot to mention that the reason INSTALLDIR is set that way is because there are some files that needs to be placed under user profile.
Please log in to comment
0

>user profile
Then your Active Setup configuration needs to do that using self-healing.

Create a parent feature whose components are targeted at the user profile folder, using whatever folder structure you need. Remember you need to set a key path using a registry value not a file. I typically use a dummy one, like this:

[HKEY_CURRENT_USER\Software\In-house\Dummy key-paths\[ProductName]\[ProductCode]]
"Installed"="[ComponentID]"

The feature you have now which contains the Active Setup value needs to then be made a child of the above feature. Its stub path needs to be set to:

MSIEXEC /fup [ProductCode]

Forget about the value of INSTALLDIR, it's irrelevant in this scenario.

First thing, though: do some reading on self-healing and Active Setup. You've posted before about problems with AS so I suspect you're still feeling your way.

Answered 04/12/2016 by: VBScab
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity