Hi all!

We have now distributed Acrobat 7 Standard and Pro with the setting to open PDFs in native Adobe Acrobat instead of within the browser (Internet Explorer). The problem is now that we have a group of people running an important application which have a bug (should be fixed in the future from the vendor) and they need to open the PDFs in the browser instead (Internet Explorer).

Do you know if this setting can easily be changed in registry or anywhere else?

Rgrds
Michael
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
This works for Acrobat Reader v7.0 so a similar method should work for your group of users :

From the Acrobat Reader v7.0 window, click Edit .. Preferences .. select "Internet" and tick the box marked Display PDF in Browser.

This setting is per-user and is stored in the following (boolean) registry value

HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\7.0\Originals\bBrowserIntegration

Regards,

Spartacus
Answered 01/25/2006 by: spartacus
Black Belt

Please log in to comment
0
Edit->Preference->Web Capture->Open Web Links ->In Acrobat
In Web Browser

You can select which ever you want...

Cheers
skj
Answered 01/25/2006 by: skj
Second Degree Brown Belt

Please log in to comment
0
Oh, my bad! The thing is that we disabled the feature (it's greyed out) of changing this setting for the users, this was done by the Adobe InstallShield Tuner. And it doesn't seem to help to change the boolean (HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\7.0\Originals\bBrowserIntegration) to 1 or 0 when we have disabled the feature.

So the real problem is really to enable this feature again. For the moment I have created a "workaround" which means that they will need to uninstall their Acrobat 7.0 and then reinstall again with my new .mst where this feature is enabled. The project checks if the user belongs to a special group then it will install the MSI with the new MST otherwise use the old one.

Today they told me that the bug fix should be finished in early february. Sigh!
Answered 01/26/2006 by: zyce
Yellow Belt

Please log in to comment
0
I don't have the requirement to grey out "Display in Browser", however, I do need to automatically turn "Display in Browser" back on. What I've noticed is that this is one of the Reader settings that cannot solely be set with the registry entry suggested above (bBrowserIntegration). It requires the setting to be made in the UI.

You may notice that when changing the value in the UI, it actually kicks off a reinstallation (some sort of msi I'm assuming). That reinstallation does not get kicked off when changing the registry entry behind the scenes. Perhaps, there is a way to script setting the registry entry and then kicking off the appropriate msi.???

BTW - I've noticed funkiness when Acrobat and Reader are installed on the same machine. I'm still researching which settings prevail under which circumstances.

Let me know what you come up with. I need to automate this as well. :)

Thanks,
Fred
Answered 02/07/2006 by: fganter
Yellow Belt

Please log in to comment
0
Perhaps you've also changed the registry key in HKLM and it's over-riding the HKCU key? If your users are locked down, that might explain why it's greyed out. Log in as an admin and see if changing the HKLM value works.
If so, you could apply a MSP I guess. What's your deployment method?
Answered 02/09/2006 by: turbokitty
Sixth Degree Black Belt

Please log in to comment
Answer this question or Comment on this question for clarity