Okay, I'm a bit stumped here, I've been creating a Basic MSI installer for the last few weeks for my client and have finally ironed out all the ICE errors, however when I test the user insterface, I get a 1606 error suggesting that the network location [ALLUSERSPROFILE]JATO cannot be accessed.  I have set this property via the property table and if I look into the log files, windows installer doesn't seem to have any issue with previous uses of the ALLUSERSPROFILE public property prior to the error.  I've attached a sample of the log below, might anybody know what is occurring during costfinalize to halt this installation?

 

MSI (c) (E0:54) [15:18:46:573]: PROPERTY CHANGE: Adding LICENCE property. Its value is 'C:\Program Files (x86)\Jato\V4\Licence\'.
MSI (c) (E0:54) [15:18:46:573]: PROPERTY CHANGE: Adding JATOINI property. Its value is 'C:\Program Files (x86)\Jato\V4\Jatoini\'.
MSI (c) (E0:54) [15:18:46:573]: PROPERTY CHANGE: Adding ERRORLST property. Its value is 'C:\Program Files (x86)\Jato\V4\Errorlst\'.
MSI (c) (E0:54) [15:18:46:573]: PROPERTY CHANGE: Adding DOCUMENTATION property. Its value is 'C:\Program Files (x86)\Jato\V4\Documentation\'.
MSI (c) (E0:54) [15:18:46:573]: PROPERTY CHANGE: Adding ISYourDataBaseDir property. Its value is 'C:\Program Files (x86)\Jato\Database\'.
MSI (c) (E0:54) [15:18:46:573]: PROPERTY CHANGE: Adding DATABASEDIR property. Its value is 'C:\Program Files (x86)\Jato\Database\'.
MSI (c) (E0:54) [15:18:46:573]: PROPERTY CHANGE: Modifying ALLUSERSPROFILE property. Its current value is 'C:\Documents and Settings\All Users'. Its new value: 'C:\Documents and Settings\All Users\'.
MSI (c) (E0:54) [15:18:46:573]: Note: 1: 1314 2: [ALLUSERSPROFILE]JATO
MSI (c) (E0:54) [15:18:46:573]: Note: 1: 1606 2: [ALLUSERSPROFILE]JATO
Error 1606.Could not access network location [ALLUSERSPROFILE]JATO.
MSI (c) (E0:54) [15:18:49:558]: Product: Jato V4.5.0.2 -- Error 1606.Could not access network location [ALLUSERSPROFILE]JATO.

MSI (c) (E0:54) [15:18:49:558]: Note: 1: 1606 2: [ALLUSERSPROFILE]JATO
Error 1606.Could not access network location [ALLUSERSPROFILE]JATO.
MSI (c) (E0:54) [15:18:50:605]: Product: Jato V4.5.0.2 -- Error 1606.Could not access network location [ALLUSERSPROFILE]JATO.

Action ended 15:18:50: CostFinalize. Return value 3.
MSI (c) (E0:54) [15:18:50:605]: Doing action: SetupCompleteError
Action 15:18:50: SetupCompleteError.
Action start 15:18:50: SetupCompleteError.

Answer Summary:
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

2

You should not use a property directly to change this. Instead use a type 51 customAction "SetAllUsersProfile" to change it to [%ALLUSERSPROFILE]\

 

Or leave it to its default value from the directory table and add the \ in the paths where you need it.

Answered 05/29/2012 by: pjgeutjens
Red Belt

  • Thanks, it turned out I had effectively created the folder entry twice so an entry in the directory table was getting in the way of the property value. I ditched the extra entry and then added the property into the directory table and all is now good.
    Unfortunately I have no choice but to declare JATOUSERDIR=[ALLUSERSPROFILE]JATO in the property table as it is fundamental to a bunch of my CA's working.
  • In that case, if I am declaring some of my folders as public properties - do I only need to declare them in the directory table rather than the property table?
  • yes, the directory table should suffice
Please log in to comment
Answer this question or Comment on this question for clarity