Patching is not completing on agents that have not been upgraded to 5.4 AP1 (5.4.10622).  Patching status goes from 'detecting' to 'completed' without deploying patches.

According to the 5.4 SP1 release notes 5.3.53177 is the minimum agent requirement.

Solution: Upgrade agents to 5.4 AP1