If you are having issues with 3.5 k2 and have a rsa not updating the drivers this might be why.

1. you are using a old imagerstore from 3.4 and Y:\hta\copy_drivers.vbs

2. make sure to check under your system images under deply options "use driver feed".

3. recheck rsa for changes